ChannelDB2

wasce-server on Ubuntu updated to 2.1.1.5

Updated version of Websphere Application Server Community Edition was uploaded into Ubuntu 10.04 LTS partners repository. Package name is wasce-server and it can be installed by using standard ubuntu package management tools.

There is problem if you are trying to update your existing wasce installation. Updates are not supported for Geronimo or WASCE. You need to install new server version, reconfigure and redeploy your application again. If you update wasce using standard ubuntu package management tools, it will fail to start.

 

You need to do:

apt-get purge wasce-server
apt-get install wasce-server

Its sad that real updates are not supported, but its just open source application server, not real websphere. It still works very well and you can redistribute it with your application.

I have quite good experience with WAS CE. Unlike JBoss and Glassfish is easy to use and it is more stable. I dont have good experience with Jboss or Glassfish 2. Glassfish 3 seems to be better.

Only problem with WASCE is that included Active MQ message broker is not very stable. I have stability problems even with newer Active MQ versions. I filled issue AMQ-3104 against ActiveMQ 5.4.2 which is newer than 4.1.2 included in WASCE. Active MQ version 4.X are known for their reliability problems.

If you are using JMS in your applications, i suggest to switch to different message broker. I have good experience with OpenMQ, which is part of Oracle Glassfish application server.

Views: 180

Comment

You need to be a member of ChannelDB2 to add comments!

Join ChannelDB2

Try BLU Acceleration on Cloud

© 2014   Created by channeldb2.

Badges  |  Report an Issue  |  Terms of Service