ChannelDB2

Hi there!

I need to use IBM DB2 with a PHP Framework like CakePHP, Yii Framework, etc. on GNU/Linux [Debian Lenny/SID] and [openSUSE 11.1/11.2].

The problem is when I try to connect to DB2... Search with "Saint Google" I found an IBM_DB2 module for Apache but I have to compile apache to able work with DB2, so... Do you have another way to use DB2 with a PHP Framework without compile Apache?

Or, if you have any experience with this or other PHP Framework feel free to tell me... I really need a hand!

Have a nice day.

Views: 857

Reply to This

Replies to This Discussion

Hi Hector,

This is a very late response, but I thought I'd mention that you don't need to compile all of Apache. You just need to have the DB2 headers (included in the IBM Data Server Client for ODBC and CLI download), gcc, and a few libraries installed. If you do, installing the extension is a matter of issuing this command:

pecl install ibm_db2

More instructions here:

http://www.db2teamblog.com/2011/02/ibmdb2-191-extension-for-php-rel...

Cheers,

Leons

RSS

Featured Downloads

Try BLU Acceleration on Cloud

© 2019   Created by channeldb2.   Powered by

Badges  |  Report an Issue  |  Terms of Service